All systems operational

Some users may be seeing delays on receiving certain emails. We are investigating the cause.

Resolved
Degraded performance
Started 12 months ago Lasted about 1 hour

Affected

Mail delivery
Updates
  • Resolved
    Resolved

    Issues with delays on mail delivery that affected a small number of users should now be resolved. We are continuing to investigate the root cause of the issue. If you see any further problems, contact support@fastmail.com.

  • Investigating
    Investigating

    We have received reports from a small number of users that some incoming mail may be slightly delayed. We are currently investigating.