Fastmail - Some mail delivery delayed – Incident details

All systems operational

Some mail delivery delayed

Resolved
Degraded performance
Started about 2 months agoLasted about 1 hour

Affected

Mail delivery

Degraded performance from 7:43 PM to 8:36 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved. Email is being delivered as expected. Existing delayed mail queues have caught up and been cleared. No mail has been lost.

  • Investigating
    Investigating

    Some emails might be delayed. We are investigating and we're looking into this incident.