Fastmail - Some users experienced interrupted access to Fastmail services. – Incident details

All systems operational

Some users experienced interrupted access to Fastmail services.

Resolved
Degraded performance
Started 14 days agoLasted about 3 hours

Affected

Web client and mobile app

Degraded performance from 3:00 AM to 5:37 AM, Operational from 5:37 AM to 6:24 AM

Updates
  • Resolved
    Resolved

    We’ve corrected the issue, and Fastmail access has been restored for all users. No mail has been lost, and we don’t anticipate further issues.

  • Monitoring
    Monitoring

    The issue has been resolved, and Fastmail access has been restored for all users. We are continuing to monitor.

  • Identified
    Identified

    We have identified a server outage that has caused interrupted access to Fastmail services. We have mitigated this and the issue should be resolved for users at this time. We are continuing to investigate and no mail has been lost during this time.