Fastmail - Third-party DNS service provider reported issues, Fastmail not impacted – Incident details

All systems operational

Third-party DNS service provider reported issues, Fastmail not impacted

Resolved
Operational
Started 1 day agoLasted about 2 hours

Affected

General Availability

Operational from 11:25 AM to 1:18 PM

Updates
  • Resolved
    Resolved

    Cloudflare is operative and did not experience any issue, the notification was sent in error during a dry run of their systems. Fastmail customers experienced no impact and we were fully operational.

  • Update
    Update

    The Cloudflare issue is ongoing however we have not had any reports of impact to Fastmail customers. We are continuing to monitor.

  • Monitoring
    Monitoring
    Cloudflare, our third-party DNS service provider, is currently having widespread issues. We are not aware of Fastmail customers being impacted, but we'll continue to monitor