All systems operational

Resolved
Network connectivity issues for some users

Started
August 29, 2023 at 6:45 AM
Status
Resolved after less than a minute

Impact

Partial outage
Affected
General Availability
  • Resolved

    This incident has been resolved. We've corrected the problem and access has been restored. No mail has been lost.

  • Identified

    Some users are seeing network-related issues with connecting to our servers.