All systems operational

Resolved
Some mail delivery delayed

Started
August 31, 2023 at 4:15 AM
Status
Resolved after about 1 hour

Impact

Degraded performance
Affected
Mail delivery
  • Resolved

    Issues with delays in mail delivery that affected some users should now be resolved. No mail has been lost. A component of our phishing protection system hit an internal limit causing the issue.

  • Identified

    Some users are seeing delays in sending and receiving certain emails.