All systems operational

Resolved
Marketing site was down for a short period

Started
December 13, 2023 at 9:00 AM
Status
Resolved after less than a minute

Impact

Operational
Affected
www.fastmail.com
  • Resolved
    Resolved

    Our marketing website www.fastmail.com was down for a short period as part of maintenance, during which time accounts continued to be accessible from https://app.fastmail.com. The service is now restored.