All systems operational

Resolved
Interrupted access to Fastmail services

Started
December 13, 2023 at 5:30 PM
Status
Resolved after 9 minutes

Impact

Operational
Affected
General Availability
  • Resolved
    Resolved

    Some users may have experienced issues during a failover. We've corrected the problem. User access has been restored. This incident has been resolved.

  • Investigating
    Investigating

    Some customers are experiencing interrupted access to Fastmail services. We're looking into it.