All systems operational

Resolved
Some mail delivery delayed

Started
February 01, 2024 at 5:10 PM
Status
Resolved after about 1 hour

Impact

Operational
Affected
General Availability
  • Resolved
    Resolved

    This incident has been resolved. No mail has been lost as a result of this incident, although delivery of some mail was delayed.

  • Investigating
    Investigating

    Some customers are experiencing delays in receiving mail. We're looking into it.