All systems operational

Resolved
Network connectivity issues

Started
February 08, 2024 at 7:33 PM
Status
Resolved after 27 minutes

Impact

Operational
Affected
Web client and mobile app
General Availability
  • Resolved
    Resolved

    This incident has been resolved.

  • Monitoring
    Monitoring

    Some users may have experienced interrupted access to Fastmail services. No mail has been lost. We're continuing to monitor the situation.