Fastmail - Interrupted access to Fastmail services – Incident details

All systems operational

Interrupted access to Fastmail services

Resolved
Degraded performance
Started about 2 months agoLasted about 14 hours

Affected

Mail delivery

Operational from 12:30 PM to 3:59 PM, Degraded performance from 3:59 PM to 2:18 AM

General Availability

Degraded performance from 12:30 PM to 1:59 PM, Operational from 1:59 PM to 12:20 AM, Under maintenance from 12:20 AM to 2:18 AM

Updates
  • Resolved
    Resolved

    This incident has been resolved. Email delivery has been restored for affected users and delayed mail have been cleared. No mail has been lost as a result of this incident.

  • Monitoring
    Update

    We're working on clearing the backlog of delayed mail and no mail has been lost. We'll continue to monitor the situation until service is back to fully operational.

  • Monitoring
    Update

    We're continuing to deliver the backlog of delayed mail and no mail has been lost. We'll continue to monitor the situation until the backlog has cleared our mail queue entirely.

  • Monitoring
    Update

    The root cause of this incident has been resolved. The backlog of delayed mail as a result of this incident is still clearing. Some users can expect further mail delays until the backlog has cleared our mail queue entirely. We are continuing to monitor the situation until all mail is being delivered without delay. No mail has been lost.

  • Monitoring
    Monitoring

    This incident has been resolved and mail delivery has returned to normal. The backlogs are still clearing, so some emails might be delayed. We are continuing to monitor.

  • Identified
    Identified

    As part of our ongoing scheduled migration, we are currently experiencing some temporary instabilities. Some emails might be delayed.