Fastmail - Problems with sending messages – Incident details

All systems operational

Problems with sending messages

Resolved
Major outage
Started 7 days agoLasted 9 minutes
Updates
  • Resolved
    Resolved

    Outgoing mail was delayed temporarily due to network connectivity issues. This incident has been resolved and no mail has been lost.

  • Identified
    Identified

    Outgoing mail is temporarily delayed due to network connectivity issues.