Fastmail - Issues with mail access – Incident details

All systems operational

Issues with mail access

Resolved
Degraded performance
Started 5 days agoLasted about 1 hour

Affected

Web client and mobile app

Degraded performance from 5:45 PM to 7:00 PM

Mail access (IMAP/POP)

Degraded performance from 5:45 PM to 7:00 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring
    We experienced a brief issue that affected access and users may have experienced slowness in loading the web interface. Access to most services remained unaffected, and no email was lost. The issue was quickly identified and we are continuing to monitor.