All systems operational

Interrupted access to Fastmail services

Resolved
Operational
Started 24 days ago Lasted about 3 hours

Affected

Web client and mobile app
Login & sessions
Updates
  • Resolved
    Resolved

    We can confirm that Fastmail connectivity issues have been resolved for both the WebUI and the Mobile Apps. All users should now be able now access our services. Network instability caused issues during a large-scale maintenance operation. Email delivery was not impacted and no mail was lost during this outage.

  • Monitoring
    Monitoring

    For most users we believe that this should now be resolved and access should now be restored to both the WebUI and our Mobile Apps. We’re continuing to monitor and will provide an additional update once we've confirmed that this is resolved.

  • Investigating
    Update

    We are currently experiencing issues with our web interface and mobile app. However access to your mail should still be available using a third-party mail client or Beta at Beta.Fastmail.com. We will continue to provide further updates to you.

  • Investigating
    Investigating
    We are currently investigating this incident.