All systems operational

Connectivity issues causing delays in accessing services

Resolved
Operational
Started 7 months ago Lasted about 2 hours

Affected

General Availability
Updates
  • Resolved
    Resolved

    Network issues between Australia and our servers in the US caused delayed responses to our Australian customers. The issue is resolved as of now. No mail was lost. We'll continue to monitor.

  • Investigating
    Investigating

    Some users are experiencing delay in accessing Fastmail services. We are investigating the issue.