Fastmail - Some users are unable to access Fastmailstatus.com – Incident details

All systems operational

Some users are unable to access Fastmailstatus.com

Resolved
Operational
Started 3 months agoLasted 8 minutes

Affected

General Availability

Operational from 1:19 AM to 1:27 AM

Updates
  • Resolved
    Resolved

    This incident has been resolved and users being unable to load Fastmailstatus.com.

  • Investigating
    Investigating

    Some users may be unable to access Fastmailstatus.com and will see it open to a blank white page. We are investigating the cause. Those users may be able to access https://fastmail.instatus.com/ in the mean time.