Fastmail - Interrupted access to web client from some locations – Incident details

All systems operational

Interrupted access to web client from some locations

Resolved
Partial outage
Started 16 days agoLasted about 1 hour

Affected

Web client and mobile app

Partial outage from 9:25 AM to 10:36 AM

Updates
  • Resolved
    Resolved

    Cloudflare has reported that the network issue has resolved and we believe this resolves the interrupted access to the Fastmail web client that users in some locations were experiencing.

  • Identified
    Identified

    Cloudflare network routing issues are affecting access to the Fastmail web client from some locations.

  • Investigating
    Investigating

    Some customers are experiencing interrupted access to Fastmail services. We're looking into it.