Fastmail - Some customers are experiencing interrupted access to Fastmail services. We're looking into it – Incident details

All systems operational

Some customers are experiencing interrupted access to Fastmail services. We're looking into it

Resolved
Major outage
Started 4 months agoLasted about 1 hour

Affected

www.fastmail.com

Major outage from 4:20 PM to 4:49 PM, Operational from 4:49 PM to 5:06 PM

General Availability

Major outage from 4:20 PM to 4:49 PM, Operational from 4:49 PM to 5:06 PM

Updates
  • Resolved
    Resolved

    Services have been restored and we are investigating the underlying issue. No mail has been lost as a result of this incident, although delivery of some mail was delayed.

  • Monitoring
    Monitoring

    Access to Fastmail should now be restored for users that were experiencing issues with connecting. We are continuing to monitor.

  • Investigating
    Update

    We are currently investigating this incident. Some users have reported that they are able to successfully access https://betaapp.fastmail.com/.

  • Investigating
    Investigating
    We are currently investigating this incident.