Fastmail - Interrupted access to Fastmail services due to Cloudflare outage – Incident details

All systems operational

Interrupted access to Fastmail services due to Cloudflare outage

Resolved
Partial outage
Started 15 days agoLasted about 3 hours

Affected

www.fastmail.com

Partial outage from 12:30 PM to 3:53 PM

Updates
  • Resolved
    Resolved

    Cloudflare has reported that this incident has been resolved.

  • Identified
    Identified

    An outage at Cloudflare, our external web hosting provider, is preventing some users from accessing www.fastmail.com. Users should still be able to access webmail by going to app.fastmail.com directly. Cloudflare hosts a large fraction of web content, so users may also see images or external links failing to load in emails.