Fastmail - Interrupted access to Fastmail services – Incident details
All systems operational
Interrupted access to Fastmail services
Resolved
Degraded performance
Started 1 day agoLasted 15 minutes
Affected
Mail delivery
Degraded performance from 7:40 AM to 7:55 AM
General Availability
Degraded performance from 7:40 AM to 7:55 AM
Updates
Resolved
Resolved
This incident has been resolved. No mail has been lost as a result of this incident.
Monitoring
Monitoring
A small number of users experienced temporary issues accessing their email due to a server issue. Fastmail services, including mail, calendars, and contacts, remained operational throughout the incident, and no data was lost.