Started 3 months agoMay 27, 2026Lasted about 3 hoursMay 27, 202610:24 PMMay 28, 20261:00 AMUTC
Affected
Mail delivery
Degraded performance from 10:24 PM to 1:00 AM
Updates
Resolved
UTC
Resolved
UTC
We identified a problem which caused intermittent outbound issues leading to some users experiencing deferrals or bounce backs. We have remediated the problem. No mail has been lost.
Investigating
UTC
Investigating
UTC
We're investigating reports of outbound mail issues. Some users have been experiencing deferrals or bounce backs on outbound messages.