Fastmail - Interrupted access to Fastmail services – Incident details

Login & sessions experiencing partial outage

Interrupted access to Fastmail services

Investigating
Partial outage
Started about 3 hours ago

Affected

Login & sessions

Partial outage from 7:25 PM to 12:00 AM

Updates
  • Update
    UTC
    Update

    We're continuing to investigate. A small number of users may experience issues accessing Fastmail services.

  • Investigating
    UTC
    Investigating

    A small number of users are experiencing issues with accessing Fastmail services. We are currently investigating this incident with our network provider.