Fastmail - Some emails are delayed – Incident details

All systems operational

Some emails are delayed

Resolved
Degraded performance
Started almost 2 years agoLasted about 2 hours

Affected

Mail delivery

Degraded performance from 1:02 PM to 1:55 PM, Operational from 1:55 PM to 3:08 PM

General Availability

Degraded performance from 1:02 PM to 1:55 PM, Operational from 1:55 PM to 3:08 PM

Updates
  • Resolved
    UTC
    Resolved

    This incident has been resolved. Email is being delivered as expected and delayed mail queues have been cleared. No mail has been lost.

  • Monitoring
    UTC
    Monitoring

    The backlog has been cleared and all the delayed emails have been delivered now. No mail has been lost. We will continue to monitor the situation

  • Investigating
    UTC
    Investigating

    As part of our ongoing scheduled migration, we are currently experiencing some instabilities and are investigating the issue. Some emails might be delayed, but no emails are lost.