All systems operational

Some customers are experiencing interrupted access to Fastmail services. We're looking into it.

Resolved
Degraded performance
Started 12 months ago Lasted about 20 hours

Affected

Web client and mobile app
Login & sessions
Mail delivery
Mail access (IMAP/POP)
Calendar (CalDAV)
File storage (WebDAV)
Updates
  • Resolved
    Update

    We wrote more about this incident and our plans for reducing the risk of similar incidents in future on our blog.

  • Resolved
    Resolved

    This incident has been resolved. Network connectivity on a limited set of routes had been interrupted due to damage to a cross-site connection. No mail has been lost as a result of this incident, although external delivery of some mail was delayed. We will be taking steps to ensure future incidents like this will be resolved more quickly.

  • Identified
    Update

    We're still having some network problems that leave a small percentage of users unable to connect with Fastmail. Investigation so far suggests that we're seeing a routing error on one route in particular into Fastmail's primary data center. We're working with our network provider and others to find an exact cause and a fix.

  • Identified
    Update

    Users in some locations continue to experience issues connecting to Fastmail services. Your ability to connect to Fastmail may vary based on your network. If possible, you may be able to connect via an alternate network, such as a VPN or mobile network.
    Some mail is delayed.

  • Identified
    Identified

    We are aware that some customers are experiencing interrupted access to Fastmail services. Our network provider is currently investigating.

  • Investigating
    Investigating