All systems operational

Resolved
Marketing site was down for a short period.

Started
July 13, 2023 at 9:32 AM
Status
Resolved after less than a minute

Impact

Degraded performance
Affected
www.fastmail.com
  • Resolved
    Resolved

    Some users experienced a temporary interrupted access to our marketing site (www.fastmail.com). Our services have been up and accessible from app.fastmail.com. No mail has been lost.