All systems operational

Resolved
IMAP/POP/SMTP connectivity issues

Started
November 28, 2023 at 2:50 AM
Status
Resolved after less than a minute

Impact

Operational
Affected
Mail access (IMAP/POP)
  • Resolved
    Resolved

    Some users were unable to connect via IMAP/POP/SMTP for 30 minutes. We've corrected the problem and access has been restored. No mail has been lost.