Fastmail - Paddle Payment Processing Issues – Incident details

Experiencing minor outage

Paddle Payment Processing Issues

Resolved
Degraded performance
Started 21 days agoLasted about 3 hours

Affected

General Availability

Degraded performance from 2:56 AM to 5:36 AM, Operational from 5:36 AM to 6:09 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    Paddle engineers have identified the cause of the incident and have taken steps to resolve the issue.

  • Investigating
    Investigating

    Our payment provider, Paddle, is currently experiencing issues which may cause errors or delays during checkout. Paddle’s team is working to resolve the problem. We'll provide an update here when we have more to share. For updates directly from Paddle, see https://paddle.status.io/.